Meeting links are down
Incident Report for Crewdle
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 20:44 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 07, 2021 - 20:43 EST
Identified
The meeting links are currently down. The issue is related with the outage at Amazon Web Services. We are currently working on a fix to get the meeting links back online.
Posted Dec 07, 2021 - 11:00 EST
This incident affected: Web App.